Amarok keeps updating collection

Whereas I could travel in 6'th up any incline between Rustenburg and Musina at the speed limits, I now have to gear down to 4'th to get up the hill between Louis Trichard and Musina.I also cannot accelerate in 6th gear below a speed of 130km/hr.

I have now done 43,000 km in 9 months with no trouble at all.

I had a long chat with the Barons Technical manager today - he confirmed that something is totally amiss.

It is also highly improbable that newer software is running with traces of older software that creates confusion for the ecu.

It sounds to me like they detuned the engine to get better consumption figures, or maybe they came across an issue in the ecu's firmware that will make the engine only last 100000km instead of 200000km or such like, and the only way to resolve it is to detune a bit.

I will be taking my Rock to VW Bruma on the 12'th on my way to Potchefstroom for a check and proper software loading....

At my 30,000 km service an ecu update was doen on my Amarok .

I am definitely unsure what you mean by your question: Ok, the problem you may be seeing is that you are getting page thrashing on that machine in turn destroying your IO bandwidth and flooding your working set with data that is not needed.

Do you really need to add this field to ALL documents eagerly, can it not be added on-demand by the application when that data is used again?

An inexperienced technician and a failed connection!

Frank, I seriously doubt that VW have such bad update processes and checks and balances in place.

An inexperienced technician and a failed connection! Then when it goes for a service, they can fiddle all they want. Then the original plug, on the other end of the supplied harness.